23rd October 2017

Search Intermittent Search Errors

Downcast is experiencing intermittent search failures due to a problem with a 3rd party service. Working on a solution ASAP.


Update: 10/24/17 @ 2:47 PM EST

A solution has been put in place that will gradually resolve the problem over the next week. Failures should be immediately reduced and disappear altogether over the next several days.

Update: 10/25/17 @ 8:28 AM EST

The solution put in place yesterday worked quicker than expected. No search failures in the last 16 hours. Resolved.